Jump to content

Partition function does not work for tracker imported from pv case after last updated (7.20)


Recommended Posts


After the last update (7.20) Pv syst does not separate correctly the PV modules into strings! I have 3 type of trackers : 1Px27, 1Px54 and 1Px81. The string length is 27 PV modules. I have to separate the trackers to 1, 2 and 3 strings according to the tracker size. Unfortunately this is not possible anymore! In result of that, the PR is higher than usual. I recalculate one project made with 7.19 version and there is difference at losses according to strings - It was 6,6% and now it is 0,00%, which I think is not correct.

Also, PVsyst recognize the tracker as 1x26, 1x53 and 1x80 instead of 1x27, 1x54 and 1x81! The dimensions (length and width) are correct, but the number of modules - not.

I can not upload the *.pvc file here (pvcase export file) in order somebody to try it, but I share some screechosts.

Please help to fix that problem!


P.S. Sometimes when import a fixed structure from PVcase (3Px9), PV syst recognize it as 4Lx5 PV modules! Why?





Link to comment
Share on other sites

Yes, that was happening in the previous versions (for example 7.19), but now it does not work.

When I chose partition, PVsyst does not apply the settings. Please see the video in the link (I could not to upload it here - an error occurs when i tried to).


The  PV moduels dimensions are 2,278x1,134 m. The length of a tracker of 81 modules (3 strings x 27 modules each) with distances between modules is exactly 92,76 m like PVsyst recognize it. But, why PVsyst calculate only 80 modules instead of 81? The same situation is with the 27 and 54-module  trackers - Pvsyst recognize the correct length, but calculate only 26 and 53 PV modules.

About the partition: On axis "Y" I have to point 3 strings, right? When I do that, the partition width automatically changed to 0,76m instead of 2,278m. If I swap the axis, then it is changed to 2.278, but I think it is not correct to point 3 strings per "X" axis. Even if I choose the swapped partition, PVsyst does not apply the settings and calculates as "linear shading" instead of "according to strings".

Link to comment
Share on other sites

We are currently working on the issue (thanks @Angelov for the example files).

Basically the partitioning for NS-axis trackers in version 7.2.20 has a bug, that will take place whenever you open a tracker definition window, e.g. to try to modify the partitioning. As far as we know there is no workaround other than reverting to 7.2.19, but a corrective should come out soon (my colleagues already fixed it on our development branch).

Link to comment
Share on other sites

For why PVsyst shows 80 modules instead of 81, check the module spacing you have in whatever software is generating the PVC file, and what you have by default in PVsyst. If for example you are using PVCase with a module spacing of .01m and your PVsyst default is .02m, you will not get the same number of modules. This does not really matter though. PVsyst is calculating shading losses here, nothing else, so if the area of the tracker block in total is representative, then I dont think it matters if it says 80 or 81. The generation calculations are done based on the system definition, not by the module quantity in the shading scene. 

Try setting PVsyst default module spacing to 0.00 (X and Y), then reimport the PVC file. 

Edited by dtarin
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...