Jump to content

Bug in batch mode version 6.3.9 of PVsyst?


spelland74
 Share

Recommended Posts

Hello,

I have been using the batch mode of PVsyst to run several meteo files for a project. With previous versions, this was working fine. In the current version, somehow PVsyst is running the first simulation in the batch twice instead of once, and doesn't do the last simulation. I have tried various solutions and been unable to fix this. I am giving an example of input batch parameters below (I have changed the files a bit to protect client privacy). In that example, when I run this batch file, the TMY gets simulated twice rather than once, and everything else is offset. The 2014 .met file does not get simulated.

Best regards,

Sophie

--

Batch parameters file (site name modified)

PVsyst simulations Batch mode;

Simulation parameters definition;

File Modified on 27/08/15 12:11;

;

Project ;;;Site TMY;

Variants based on;;VC0;Detailed losses;

;

Please define the parameters to be varied for each run;

Don't modify anything in the column titles !;

Only the lines beginning by "SIM_" will be executed;

;

Ident;Meteo data;Simul;;

;*.MET file;Comment;;

;;;;

;

SIM_1; Site_TMY.MET;Detailed losses;;

SIM_2; Site_2000.MET;Detailed losses;;;

SIM_3; Site_2001.MET;Detailed losses;;;

SIM_4; Site_2002.MET;Detailed losses;;;

SIM_5; Site_2003.MET;Detailed losses;;;

SIM_6; Site_2004.MET;Detailed losses;;;

SIM_7; Site_2005.MET;Detailed losses;;;

SIM_8; Site_2006.MET;Detailed losses;;;

SIM_9; Site_2007.MET;Detailed losses;;;

SIM_10; Site_2008.MET;Detailed losses;;;

SIM_11; Site_2009.MET;Detailed losses;;;

SIM_12; Site_2010.MET;Detailed losses;;;

SIM_13; Site_2011.MET;Detailed losses;;;

SIM_14; Site_2012.MET;Detailed losses;;;

SIM_15; Site_2013.MET;Detailed losses;;;

SIM_16; Site_2014.MET;Detailed losses;;;

;;

Don't forget to close this file in EXCEL before returning to PVsyst for executing the simulation !!!;;

Link to comment
Share on other sites

I have just downloaded again version 6.3.8 and can confirm that there is no issue running my simulation with the batch parameter file I showed in the previous post. The issue only occurs for 6.3.9, so I believe there is a bug in the 6.3.9 batch algorithms.
Link to comment
Share on other sites

  • 5 months later...

I just updated to 6.41 and have found that the issue has changed. I run multiple meteo files, and run each meteo file with a change of a parameter.

Now when I run multiple meteo files in batch, the first run of a meteo file uses the correct meteo file, but the following runs use the first year I specified.

 

Ident	Meteo data	Mod. quality	Simul	Error	GlobHor	T_Amb	GlobInc	FTransp	E_Grid	PR
*.MET file	loss	Comment		kWh/m²	°C	kWh/m²		kWh	
	[%]								
									
>>SIM_1998_01	SiteName_1998.MET	0.0	 Base Case 1998 Year 1		1545	15.25	1948	1.261	177748415	0.8147
SIM_1998_10	SiteName_1998.MET	4.4	 Base Case 1998 Year 10		1545	15.25	1948	1.261	171547707	0.7863
SIM_1998_20	SiteName_1998.MET	9.0	 Base Case 1998 Year 20		1545	15.25	1948	1.261	164347079	0.7533
>>SIM_1999_01	SiteName_1999.MET	0.0	 Base Case 1999 Year 1		1568	14.51	1994	1.272	184156118	0.8245
SIM_1999_10	SiteName_1999.MET	4.4	 Base Case 1999 Year 10		1545	15.25	1948	1.261	171547707	0.7863
SIM_1999_20	SiteName_1999.MET	9.0	 Base Case 1999 Year 20		1545	15.25	1948	1.261	164347079	0.7533
>>SIM_2000_01	SiteName_2000.MET	0.0	 Base Case 2000 Year 1		1621	13.65	2104	1.298	194100553	0.8235
SIM_2000_10	SiteName_2000.MET	4.4	 Base Case 2000 Year 10		1545	15.25	1948	1.261	171547707	0.7863
SIM_2000_20	SiteName_2000.MET	9.0	 Base Case 2000 Year 20		1545	15.25	1948	1.261	164347079	0.7533

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...