Jump to content

When starting PVsyst I get: "The application can not start because it is not signed by PVsyst SA." (PVsyst 7)


Recommended Posts

Solution #1

When PVsyst is starting Windows checks if it is coming from PVsyst SA to ensure that this is an authentic copy of the software. This should guarantee that PVsyst is virus and malware free.

If this check is failing a pop up is displayed: "The application can not start because it is not signed by PVsyst SA."

pvsyst-app_can_not_start.png.ea66a4a5493e160a97f8c45ed3128e35.png

If you downloaded PVsyst from http://www.pvsyst.com, the error is probably appearing because you are using an old Windows, which does not contain our security partner's certificate.

Please follow this procedure to update your Windows certificate list:

- In Windows, start menu >> Control panel >> Add or remove program >> Add/Remove Windows component

- check "Update Root certificates"

- click OK.

- then restart the computer.

Solution #2

It looks like sometimes, asking Windows to update certificates is not enough: it does not install the correct certificates.

The other solution is to install certificates manually. Here is the procedure.

1.Download these 2 certificates:

- https://cacerts.digicert.com/DigiCertTrustedG4CodeSigningRSA4096SHA3842021CA1.crt

- https://cacerts.digicert.com/DigiCertTrustedRootG4.crt

2. Install these 2 certificates, so for each of them:

- Double click on it

- "Install certificate"

- "Next", "Next",... (keep the default options) until the end.

Start PVsyst again.

Solution #3

If you are using Windows 7 and still encountering this issue, the following may be useful.

First of all, you need to be logged in as an Administrator on the computer.

Download the two following certificates :

https://cacerts.digicert.com/DigiCertTrustedG4CodeSigningRSA4096SHA3842021CA1.crt

https://cacerts.digicert.com/DigiCertTrustedRootG4.crt

For each certificate :

1. Double-click the file

2. Click on Install certificate

3. Click on Next

4. Select Place all certificates in the following store, click Browse, check Show physical stores, select Trusted publishers > Local computer

5. Click OK, click Next, click Terminate

Try running PVsyst again, and if adding both certificates still doesn't fix it, try the following steps :

1. Click Start, click Start Search, type mmc, and then press ENTER.

2. On the File menu, click Add/Remove Snap-in.

3. Under Available snap-ins, click Local Group Policy Object Editor, click Add, select the computer whose local Group Policy object (GPO) you want to edit, and then click Finish.

4. Click OK.

4. In the console tree, go to Local Computer Policy, Computer Configuration, Windows Settings, Security Settings, and then click Public Key Policies.

5. Double-click Certificate Path Validation Settings, and then click the Stores tab.

6. Select the Define these policy settings check box.

7. Under Per user certificate stores, clear the Allow user trusted root CAs to be used to validate certificates and Allow users to trust peer trust certificates check boxes.

8. Under Root certificate stores, select the Enterprise and third-party certification authorities radio, and then click OK to apply the new settings.

And then try to run PVsyst again.

Link to comment
Share on other sites

 Share

×
×
  • Create New...