Jump to content

"Maximum Field/Shadings Area ratio" ignored


johank
 Share

Recommended Posts

Hi,

I have purposely set a high field/shadings area ratio but still get an error that

"The area of the 3D fields is lower than the area of the modules defined in the subarrays."

See screenshots - I think the ratio here is ~28, below the project's / default limit.

Thanks!

1773730838_ProjectSettings.jpg.5b26afc59d77af367bae8f07e456aadf.jpg

1741786832_ShadingScene.png.3b0a4d3161fecee970a2e91f3e6fbb3a.png

Link to comment
Share on other sites

You can modify in advanced parameters. There might be conflict in PVsyst between the setting shown in project settings and the setting in advanced parameters, they are referenced in opposite ways (shading/field vs field/shade). I have always modified in advanced settings with no issues.

2022-02-22_14-36-57.png.b953b7dcb6e2c4bb27a544c6febf23d5.png

Link to comment
Share on other sites

Thanks dtarin! I have it set up as in the attached, the "80.0" for this project was a test to see if changing the parameter by-project made any difference (it did not).

Stephane, thanks for the reply - how is the ratio calculated?

I'm OK with a high ratio here, as it just needs to be a representative tracker block (for a large tracking array). There are no significant external shadings.

943637455_2022-02-2817_02_02-Editadvancedparameters.png.167926144259d24fe19ef6e89e846d64.png

Link to comment
Share on other sites

  • 2 weeks later...

... right, clearly did not read that closely enough: it's the minimum ratio that was causing the error.

As dtarin said above, the definition is different depending on which settings you're in:

  • Advanced parameters: "shading scene active area" / "system definition active area".
  • Project settings: "system active area" / "shading scene active area" (I think)

Setting lower minimum ratios in advanced settings made the error go away. Yay!

2022-03-15 20_48_22-Edit advanced parameters.png

Link to comment
Share on other sites

Pay attention, the values you show by screenshot are far from the default values:

image.png.8a4fcf66354136f31a67a31010688148.png

The "Maximum Field/Shadings area ratio" parameter in the project parameters corresponds well to the "Shadings: absolute maximum shading/field area ratio" from the advanced settings. The label is wrong, you have to read "Shadings/Field" instead of "Field/Shadings". I will correct the text in the software.

image.png.b7cf8f5d368f9300ffe52d3a77824db9.png

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...