PVsyst's forum
https://forum.pvsyst.com/

bug when creating a shading scene (VirtualBox)
https://forum.pvsyst.com/viewtopic.php?f=4&t=3131
Page 1 of 1

Author:  Al1 [ Wed Sep 13, 2017 4:30 pm ]
Post subject:  bug when creating a shading scene (VirtualBox)

Hello,

I use PVSyst (still in evaluation mode) in a Windows 10 virtual machine under Ubuntu 16.04, using VirtualBox. I can create a system and simuate it but I am unable to create any object in the shading scene. First I didn't receive any error message but now PVSyst crashes as try to close the window where you are supposed to create an object. What is going wrong?

Author:  ClaudioPaixao [ Mon Sep 18, 2017 2:23 pm ]
Post subject:  Re: bug when creating a shading scene (VirtualBox)

I have a similar problem.

Not even the menu on the right side seens to be working because it doesn´t retract and activate correctly.

I am using VirtualBox 5.1.28 running a Windows 8.1 32 bits installation. No other software is running. This virtual machine was created with the only purpose of testing PVSyst.

Is it required a 64bit Windows version in the Virtual Machine?

Author:  sylvain@pvsyst [ Thu Sep 21, 2017 12:01 pm ]
Post subject:  Re: bug when creating a shading scene (VirtualBox)

Hello,

Please make sure that you have enabled 3D acceleration for the virtual machine.
Also make sure that the host graphics drivers are up-to-date, more info here : viewtopic.php?f=17&t=2771

Author:  Al1 [ Fri Sep 14, 2018 1:02 pm ]
Post subject:  Re: bug when creating a shading scene (VirtualBox)

Hello,
The bug is still there. I had to use another computer to be able to work with PVsyst. But this time I will have to make it work on my laptop because I will need it for a training coming soon.
3D acceleration is enabled and the graphics driver must be up to date as I've got an Intel® HD Graphics 620 (Kaby Lake GT2) wich is automatically supported by Ubuntu (now version 18.04). Then I have still no idea of what the problem is.
The scene remains white in the windows where you must create objects. I can actually create objects but they don't appear in the scene. As long as no object is created, the main scene shows the grid and I can zoom in or out and rotate it. But as soon as an object is created, this one is not visible and zoom or rotate the grid anymore. In some cases, the grid is not even there, it's just all white. However the created object appears in the objects list on the right.

Author:  Al1 [ Mon Oct 08, 2018 2:51 pm ]
Post subject:  Re: bug when creating a shading scene (VirtualBox)

News about my topic:

The problem is that the 3D scenes in PVsyst require OpenGL 2.1 at least, whereas Virtualbox provides support only for OpenGL 1.1 for Windows 10 (actually Windows 8+). I couldn't find any work around.

Then I tried to run PVsyst through Wine. Installing Wine, then PVsyst and launching it was not straight forward, but it works! Not perfectly though, as I can't open the Meteonorm database, nor the help documentation and can't edit a report. But the 3D scene works fine and the simulation too.

I hope that this would help anyone in the same situation.

Page 1 of 1 All times are UTC+02:00
Powered by phpBB® Forum Software © phpBB Limited
https://www.phpbb.com/